Back to overview
Increased response latency
Nov 03 at 01:18pm PST
Affected services
Services
Resolved
Nov 03 at 01:18pm PST
Users have reported seeing increased response latencies. Our team is investigating the issue.
Update 1: We have identified the issue. Our team is working on a fix.
Update 2: Issue has been resolved
Affected services
Services