Back to overview
Degraded
Ask Unblocked feature is experiencing increased latency and error rates.
Mar 17, 2026 at 7:44pm UTC
Affected services
Ask Unblocked
Resolved
Mar 17, 2026 at 9:44pm UTC
Issue has been resolved
Affected services
Updated
Mar 17, 2026 at 8:57pm UTC
Ask Unblocked feature is experiencing increased latency and error rates due to an on-going service outage on Anthropic.
We’ll share another update shortly.
Affected services
Updated
Mar 17, 2026 at 8:34pm UTC
Issue has been resolved
Affected services
Created
Mar 17, 2026 at 7:44pm UTC
Ask Unblocked feature is experiencing increased latency and error rates due to an on-going service outage on Anthropic.
We’ll share another update shortly.
Affected services