Back to overview

Increased API latency

Mar 18, 2026 at 6:55pm UTC
Affected services
Services
Web Dashboard
Public API Service
Ask Unblocked

Resolved
Mar 18, 2026 at 6:55pm UTC

Our team is investigating increased latencies in API calls.

Update 1 12:26PM PDT: We have applied temporary fix to help reduce latencies while our team is investigating the root cause.

Update 2 12:55PM: Issue has been resolved.