Back to overview

Slack webhook processing delays

Sep 26 at 05:00pm PDT
Affected services
Ask Unblocked

Resolved
Sep 26 at 05:00pm PDT

We are seeing increased delays in processing Slack webhook events impacting data ingestion and user experience through Unblocked Slack bot.

Our team is investigating the issue.

Update 1 - 2:38PM PST:
Our time continues troubleshooting the issue. Ingestion functionality is partially restored. We are working on restoring Slack bot service.

Update 2 - 5:11PM PST:
Bot issue has been resolved

Final update and root cause:
This issue was caused by Slack API and unnecessary throttling of API calls by Slack. All Unblocked services were operating as normal and as soon as Slack API was restored we resumed processing events.